Cisco Configuration Info

Configuration information for a Cisco 2811 running IOS IP Voice 12.4.24T

Provided by: Staffan Kerker

Cisco Configuration Info for IOS 12.2

The following configuration file example is known to work when configuring sipX with a Cisco SIP Gateway FXO setup. You must replace parameters within the file (e.g., ip address 10.1.##.# 255.255.###.#) with your site specific parameters when you copy the file through a terminal window into the Cisco Gateway.

  1. Copy the following example, starting with the first exclamation point (warning) and ending with end (end).
  2. Open a terminal window/telnet to the Cisco gateway.
  3. At a command prompt enter the Write to Screen command (e.g., Cisco#wr t) after gaining access through protected mode (enter the "enable" command at a command line prompt to enter protected mode and a # sign displays with the prompt) and a similar configuration displays.
  4. Type the config command to enter an editable mode and copy the file example into the Cisco gateway.

    !

    ! Last configuration change at 12:45:06 GMT Thu Apr 21 2005

    ! NVRAM config last updated at 12:45:29 GMT Thu Apr 21 2005

    !

    version 12.2

    service timestamps debug datetime msec

    service timestamps log datetime

    no service password-encryption

    !

    hostname SIPxchangeGW

    !

    boot system flash:

    logging console informational

    logging monitor warnings

    enable secret 5 $1$fzy9$AZFTI7pk7wB.eeH6ELL6R0

    enable password P1ng-Restart!!

    !

    Enabling FXS interface registration on Cisco SIP Gateway:
    clock timezone GMT -5

    ip subnet-zero

    !

    !

    ip tcp path-mtu-discovery

    ip domain list pingtel.com

    ip domain name pingtel.com

    ip name-server 10.1.#.##

    !

    !

    !

    template mon

    !

    !

    voice call carrier capacity active

    !

    voice service voip

    sip

    !

    voice class codec 1

    codec preference 1 g711ulaw

    codec preference 2 g711alaw

    codec preference 3 g729br8

    !

    !

    !

    !

    !

    !

    !

    !

    voice source-group secured

    access-list 1

    disconnect-cause call-reject

    !

    !

    fax interface-type fax-mail

    mta receive maximum-recipients 0

    !

    !

    !

    !

    interface Ethernet0/0

    ip address 10.1.##.# 255.255.###.#

    no ip mroute-cache

    half-duplex

    !

    interface Ethernet0/1

    ip address 10.1.##.# 255.255.###.#

    no ip mroute-cache

    shutdown

    full-duplex

    !

    ip default-gateway 10.1.##.#

    ip classless

    ip route 0.0.0.0 0.0.0.0 10.1.##.#

    ip route 10.1.#.# 255.255.###.# 10.1.##.#

    no ip http server

    !

    !

    logging 10.1.#.##

    !

    snmp-server packetsize 4096

    snmp-server enable traps tty

    call rsvp-sync

    !

    voice-port 1/0/0

    input gain 8

    no vad

    connection plar 100

    description SIPxchange1

    caller-id enable

    supervisory disconnect dualtone pre-connect

    supervisory answer dualtone

    !

    voice-port 1/0/1

    input gain 8

    no vad

    connection plar 100

    description SIPxchange2

    caller-id enable

    supervisory disconnect dualtone pre-connect

    supervisory answer dualtone

    !

    voice-port 1/1/0

    input gain 8

    no vad

    connection plar 100

    description SIPxchange3

    caller-id enable

    supervisory disconnect dualtone pre-connect

    supervisory answer dualtone

    !

    voice-port 1/1/1

    input gain 8

    no vad

    connection plar 100

    description SIPxchange4

    caller-id enable

    supervisory disconnect dualtone pre-connect

    supervisory answer dualtone

    !

    !

    mgcp profile default

    !

    dial-peer cor custom

    !

    !

    !

    dial-peer voice 100 voip

    huntstop

    application session

    destination-pattern ...

    rtp payload-type nte 98

    voice-class codec 1

    session protocol sipv2

    session target sip-server

    dtmf-relay rtp-nte

    !

    dial-peer voice 10 pots

    huntstop

    application session

    destination-pattern 1..........

    port 1/0/0

    forward-digits all

    !

    dial-peer voice 11 pots

    huntstop

    application session

    destination-pattern 1..........

    port 1/0/1

    forward-digits all

    !

    dial-peer voice 12 pots

    huntstop

    application session

    destination-pattern 1..........

    port 1/1/0

    forward-digits all

    !

    dial-peer voice 13 pots

    huntstop

    application session

    destination-pattern 1..........

    port 1/1/1

    forward-digits all

    !

    dial-peer voice 30 pots

    huntstop

    application session

    destination-pattern 911$

    port 1/0/0

    forward-digits all

    !

    dial-peer voice 31 pots

    huntstop

    application session

    destination-pattern 911$

    port 1/1/0

    forward-digits all

    !

    dial-peer voice 32 pots

    huntstop

    application session

    destination-pattern 911$

    port 1/0/1

    forward-digits all

    !

    dial-peer voice 33 pots

    huntstop

    application session

    destination-pattern 911$

    port 1/1/1

    forward-digits all

    !

    dial-peer voice 40 pots

    huntstop

    application session

    destination-pattern 411$

    port 1/0/0

    forward-digits all

    !

    dial-peer voice 41 pots

    huntstop

    application session

    destination-pattern 411$

    port 1/1/0

    forward-digits all

    !

    dial-peer voice 50 pots

    huntstop

    application session

    destination-pattern 9...$

    port 1/0/0

    forward-digits 3

    !

    dial-peer voice 51 pots

    huntstop

    application session

    destination-pattern 9...$

    port 1/0/1

    forward-digits 3

    !

    dial-peer voice 52 pots

    huntstop

    application session

    destination-pattern 9...$

    port 1/1/0

    forward-digits 3

    !
    dial-peer voice 53 pots

    huntstop

    application session

    destination-pattern 9...$

    port 1/1/1

    forward-digits 3

    !

    dial-peer voice 20 pots

    huntstop

    application session

    destination-pattern .......$

    port 1/0/0

    forward-digits all

    prefix 1781

    !

    dial-peer voice 21 pots

    huntstop

    application session

    destination-pattern .......$

    port 1/0/1

    forward-digits all

    prefix 91781

    !

    dial-peer voice 22 pots

    huntstop

    application session

    destination-pattern .......$

    port 1/1/0

    forward-digits all

    prefix 91781

    !

    dial-peer voice 23 pots

    huntstop

    application session

    destination-pattern .......$

    no digit-strip

    port 1/1/1

    forward-digits all

    prefix 91781

    !

    dial-peer voice 14 pots

    huntstop

    application session

    destination-pattern ..........

    port 1/0/0

    forward-digits all

    prefix 1

    !

    dial-peer voice 15 pots

    huntstop

    application session

    destination-pattern ..........

    port 1/0/1

    forward-digits all

    prefix 1

    !

    dial-peer voice 16 pots

    huntstop

    application session

    destination-pattern ..........

    port 1/1/0

    forward-digits all

    prefix 1

    !

    dial-peer voice 17 pots

    huntstop

    application session

    destination-pattern ..........

    port 1/1/1

    forward-digits all

    prefix 1

    !

    dial-peer voice 60 pots

    huntstop

    application session

    destination-pattern 011.+

    port 1/0/0

    forward-digits all

    !

    dial-peer voice 61 pots

    huntstop

    application session

    destination-pattern 011.+

    port 1/0/1

    forward-digits all

    !

    dial-peer voice 62 pots

    huntstop

    application session

    destination-pattern 011.+

    port 1/1/0

    forward-digits all

    !

    dial-peer voice 63 pots

    huntstop

    application session

    destination-pattern 011.+

    port 1/1/1

    forward-digits all

    !

    dial-peer voice 70 pots

    huntstop

    application session

    destination-pattern 00$

    port 1/0/0

    forward-digits all

    !

    dial-peer voice 71 pots

    huntstop

    application session

    destination-pattern 00$

    port 1/1/0

    forward-digits all

    !

    dial-peer voice 72 pots

    huntstop

    application session

    destination-pattern 00$

    port 1/0/1

    forward-digits all

    !

    dial-peer voice 73 pots

    huntstop

    application session

    destination-pattern 00$

    port 1/1/1

    forward-digits all

    !

    dial-peer voice 101 voip

    huntstop

    application session

    destination-pattern A-Z.....................

    rtp payload-type nte 98

    voice-class codec 1

    session protocol sipv2

    session target sip-server

    dtmf-relay rtp-nte

    !

    dial-peer voice 130 pots

    huntstop

    application session

    destination-pattern 0$

    port 1/0/0

    forward-digits all

    !

    dial-peer voice 131 pots

    huntstop

    application session

    destination-pattern 0$

    port 1/1/0

    forward-digits all

    !

    dial-peer voice 132 pots

    huntstop

    application session

    destination-pattern 0$

    port 1/0/1

    forward-digits all

    !

    dial-peer voice 133 pots

    huntstop

    application session

    destination-pattern 0$

    port 1/1/1

    forward-digits all

    !

    gateway

    timer receive-rtcp 5

    !

    sip-ua

    max-forwards 15

    no oli

    sip-server dns:pingtel.com

    !

    !

    line con 0

    exec-timeout 0 0

    line aux 0

    exec-timeout 0 0

    line vty 0 4

    exec-timeout 0 0

    password sip

    login

    line vty 5 15

    login

    !

    ntp clock-period 17181250

    ntp source Ethernet0/0

    ntp server 192.43.244.18

    !

    end

Enabling FXS interface registration on Cisco SIP gateway:

if you plan to use your Cisco device as both a gateway and for registered FXS users, you must create explicit custom rules in your dialplan for your FXS users otherwise sipXpbx authorization subsystem will not allow calls to your users on the Cisco device. That is because they share the same IP address as your gateway.sip-ua
registrar dns:sipserver expires 3600

sip-ua
registrar dns:sipserver expires 3600
!

dial-peer voice 562 pots
!--- the following will be used as the registration name
destination-pattern 0562
port 0/0/2
!--- sipXpbx requires that the username and registration name must be the same
!--- Cisco IOS requires that the username must be at least 4 characters long
authentication username 0562 password 1234
!